Select Language

 flag en  flag pl

Facebook
Hits: 1318

Download

This is a minor update providing compatibility with DLC Iberia.

If you do not have the Iberia DLC, do not update and stay with 2.52.
The Iberia DLC is not required to run 2.55 but you will lose Spain entirely.

Map Changes:

General: Many bug fixes and tweaks versus 2.52

You must own the Going East! DLC, the Scandinavian DLC, the Vive La France! DLC , Italia DLC, Beyond the Baltic Sea DLC as well as the Road to the Black Sea DLC in order for ProMods to work